import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\/.+)|(#.+)|('.+)|(\\/\\*[^(\\*\\/)]+?\\*\\/)|(\\\"{3}[^(\\\"{3})]+?\\\"{3})";
final String string = "# Đây là 1 dòng comment\n\n"
+ "/*\n"
+ " Đây là block comment\n"
+ "*/\n\n"
+ "// Đây là một dòng comment\n\n"
+ "'Comment tiếp nè\n\n"
+ "\"\"\"\n"
+ "Comment tiếp nè\n"
+ "\"\"\"\n\n"
+ "#include <iostream>\n"
+ "#include <regex>\n"
+ "using namespace std;\n"
+ " \n"
+ "int main() {\n"
+ " // your code goes here\n"
+ " return 0;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}