re = /ng-repeat="([a-zA-Z]*)\s+(in)\s+([a-zA-Z\.{1}().]*)\s+track by \$index"/
str = 'ng-repeat="research in researches.main track by $index"
ng-repeat="research in researches track by $index"
ng-repeat="patient in patientGroup.getPatients() track by $index"
ng-repeat="survey in model.getResearches().sub track by $index"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end