$re = '/^(?:98|\+98|0098|0)?9[0-9]{9}$/m';
$str = '09121234567
00989121234567
+989121234567
9121234567
989121234567
+18087339090
+918087339090
+9128087339090
8087339090
08087339090
+1-8087339090
+91-8087339090
+912-8087339090';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);