package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)(?'nonbrace' [^{}\n] ))
(?(DEFINE)(?'begin' { ))
(?(DEFINE)(?'end' } ))
(?(DEFINE)(?'middle' (?&nonbrace) ))
(?(DEFINE)(?'nested'
((?&begin)((?&middle)|(?&nested))*(?&end))
))
^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$`)
var str = `
a
abc
{}
{a}
{{aa}}
{a{b}}
{a{bb}a}
{a{b{c}b}a}
n{a{}}nn{b{bb}}
\@writefile{toc}}}}{\contentsline {section}{\numberline {B
\@writefile{toc}{\contentsline {section}{\numberline {B
Previous lines contain mismatched braces. This and the next line don't.
\@writefile{toc}{\contentsline {section}{\numberline {B}}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}