const regex = /(?(DEFINE)(?'nonbrace' [^{}\n] ))
(?(DEFINE)(?'begin' { ))
(?(DEFINE)(?'end' } ))
(?(DEFINE)(?'middle' (?&nonbrace) ))
(?(DEFINE)(?'nested'
((?&begin)((?&middle)|(?&nested))*(?&end))
))
^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?\'nonbrace\' [^{}\\n] ))
(?(DEFINE)(?\'begin\' { ))
(?(DEFINE)(?\'end\' } ))
(?(DEFINE)(?\'middle\' (?&nonbrace) ))
(?(DEFINE)(?\'nested\'
((?&begin)((?&middle)|(?&nested))*(?&end))
))
^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$', 'mg')
const str = `
a
abc
{}
{a}
{{aa}}
{a{b}}
{a{bb}a}
{a{b{c}b}a}
n{a{}}nn{b{bb}}
\\@writefile{toc}}}}{\\contentsline {section}{\\numberline {B
\\@writefile{toc}{\\contentsline {section}{\\numberline {B
Previous lines contain mismatched braces. This and the next line don't.
\\@writefile{toc}{\\contentsline {section}{\\numberline {B}}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}