const regex = /(.+)-(\d+)\s+(.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)-(\\d+)\\s+(.+)', 'g')
const str = `alabala-1000 Intern`;
const subst = `$1/$1-$2/$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);