#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[-+]?([1-8]?\d(\.\d+)?|90?|90(\.0+)?){1}\s{1}[-+]?(180{1}|180(\.0+){1}|((1[0-7]\d{1})|([1-9]?\d){1})(\.\d+)?)\s?([-+]?(\d+(\.0+)?))?$"
Local $sString = "90 125 23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")