import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+]?([1-8]?\\d(\\.\\d+)?|90?|90(\\.0+)?){1}\\s{1}[-+]?(180{1}|180(\\.0+){1}|((1[0-7]\\d{1})|([1-9]?\\d){1})(\\.\\d+)?)\\s?([-+]?(\\d+(\\.0+)?))?$";
final String string = "90 125 23";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}