# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\n\b/ /gm;t' <<< "Paragraph1
Paragraph2
Paragraph2
Paragraph2
Paragraph2
Paragraph3
Paragraph3
Paragraph4"