import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\n\\b";
final String string = "Paragraph1\n\n"
+ "Paragraph2\n"
+ "Paragraph2\n"
+ "Paragraph2\n"
+ "Paragraph2\n\n"
+ "Paragraph3\n"
+ "Paragraph3\n\n"
+ "Paragraph4";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}