// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\n\b").unwrap();
let string = "Paragraph1
Paragraph2
Paragraph2
Paragraph2
Paragraph2
Paragraph3
Paragraph3
Paragraph4";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}