// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]\.[a-zA-Z]\.(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})@uts\.edu\.co$").unwrap();
let string = "j.g.1999@uts.edu.co
j.g.2018@uts.edu.co
j.g.2019@uts.edu.co
j.g.2020@uts.edu.co
j.g.2099@uts.edu.co
j.g.2119@uts.edu.co
j.g.4904@uts.edu.co";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}