#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<Name>\w+)\s\w+\s(?<Major>\*|\d+)\.?(?<Minor>\*|\d+)?\.?(?<Patch>\*|\d+)?"
Local $sString = "Android OS 5.1 / API (LYZ28N/500200305)" & @CRLF & _
"Android OS 5.1.1 / API (LYZ28N/500200305)" & @CRLF & _
"Android OS 10 / API-29 (LYZ28N/500200305)" & @CRLF & _
"Android OS 102222.1323121312 / API-29 (LYZ28N/500200305)" & @CRLF & _
"iPhone OS 5.12 / API (LYZ28N/500200305)" & @CRLF & _
"iPhone OS 5 / API (LYZ28N/500200305)" & @CRLF & _
"iPhone OS 5.1.10000.1.1.1.1.1.1.1.1 / API (LYZ28N/500200305)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")