# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<Name>\w+)\s\w+\s(?<Major>\*|\d+)\.?(?<Minor>\*|\d+)?\.?(?<Patch>\*|\d+)?"
test_str = ("Android OS 5.1 / API (LYZ28N/500200305)\n"
"Android OS 5.1.1 / API (LYZ28N/500200305)\n"
"Android OS 10 / API-29 (LYZ28N/500200305)\n"
"Android OS 102222.1323121312 / API-29 (LYZ28N/500200305)\n"
"iPhone OS 5.12 / API (LYZ28N/500200305)\n"
"iPhone OS 5 / API (LYZ28N/500200305)\n"
"iPhone OS 5.1.10000.1.1.1.1.1.1.1.1 / API (LYZ28N/500200305)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.