use strict;
my $str = ' Force [N]
Stress [MPa] ';
my $regex = qr/^[ ]+|[ ]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";