use strict;
my $str = '99999999
12345.66
1234
abc99999999
99999999abc';
my $regex = qr/\b\d{4}\K\d+\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";