package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z]{1})`)
var str = `SONG
Another test Songtitle
SongTitle
So.la.la
What, if a comma or 123 or ??? would be in the name?
Special characters like # or ! or % or anything else?
`
var substitution = "$1."
fmt.Println(re.ReplaceAllString(str, substitution))
}