#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[ERROR\:.*?:program2"
Local $sString = "[ERROR:location1:program1.34]" & @CRLF & _
"[ERROR:location10:program2.10]" & @CRLF & _
"[ERROR:location4:program2.45]" & @CRLF & _
"[ERROR:location9:program1.30]" & @CRLF & _
"[ERROR:location2:program2.60]" & @CRLF & _
"[INFO:location2:program2.60]" & @CRLF & _
"[WARN:location4:program2.45]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")