using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[ERROR\:.*?:program2";
string input = @"[ERROR:location1:program1.34]
[ERROR:location10:program2.10]
[ERROR:location4:program2.45]
[ERROR:location9:program1.30]
[ERROR:location2:program2.60]
[INFO:location2:program2.60]
[WARN:location4:program2.45]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}