use strict;
my $str = '[ERROR:location1:program1.34]
[ERROR:location10:program2.10]
[ERROR:location4:program2.45]
[ERROR:location9:program1.30]
[ERROR:location2:program2.60]
[INFO:location2:program2.60]
[WARN:location4:program2.45]
';
my $regex = qr/\[ERROR\:.*?:program2/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}