$re = '/\[ERROR\:.*?:program2/m';
$str = '[ERROR:location1:program1.34]
[ERROR:location10:program2.10]
[ERROR:location4:program2.45]
[ERROR:location9:program1.30]
[ERROR:location2:program2.60]
[INFO:location2:program2.60]
[WARN:location4:program2.45]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);