import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\$Log:.*[\\r\\n]*.*[\\r\\n])(.*)";
final String string = "/*\n"
+ "******************************************************************\n"
+ "$Log: oldfile.c,v $\n"
+ "Revision 11.4 2000/01/20 19:01:41 userid\n"
+ "blah blah blah\n\n"
+ "*/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}