use strict;
my $str = '/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/';
my $regex = qr/(\$Log:.*[\r\n]*.*[\r\n])(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}