import re
regex = re.compile(r"(\$Log:.*[\r\n]*.*[\r\n])(.*)")
test_str = ("/*\n"
"******************************************************************\n"
"$Log: oldfile.c,v $\n"
"Revision 11.4 2000/01/20 19:01:41 userid\n"
"blah blah blah\n\n"
"*/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")