using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<ALL>[^H\n\r]*(?:(?<ID>H-\d{4}).*|.[^H\n\r]*)*)";
string input = @"Sample line with H-5722 id
Sample line without id
Sample line without id H.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}