package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<ALL>[^H\n\r]*(?:(?<ID>H-\d{4}).*|.[^H\n\r]*)*)`)
var str = `Sample line with H-5722 id
Sample line without id
Sample line without id H.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}