const regex = /^(?<ALL>[^H\n\r]*(?:(?<ID>H-\d{4}).*|.[^H\n\r]*)*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<ALL>[^H\\n\\r]*(?:(?<ID>H-\\d{4}).*|.[^H\\n\\r]*)*)', 'mg')
const str = `Sample line with H-5722 id
Sample line without id
Sample line without id H.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}