import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<(/|)(!--|div|span|a|img|p)[^>]*>(\\n|)| )";
final String string = "mass <=45 and >=30g\n"
+ "Contrary to <FM>\n"
+ "reading < 2 DAC hours ... reading > 2 DAC hours\n"
+ "Landon <lando@master.lanl.gov>\n"
+ "<!-- this is an html comment -->\n"
+ "<DIV>\n"
+ "<div></div>\n"
+ "<p>\n"
+ "<P>\n"
+ "<SPAN>\n"
+ "<span style=\"stuff and yo\">\n"
+ "<a href=\"\"><img src=\"https://lanl.com\"></a>\n"
+ "Here is: more text";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}