use strict;
my $str = 'mass <=45 and >=30g
Contrary to <FM>
reading < 2 DAC hours ... reading > 2 DAC hours
Landon <lando@master.lanl.gov>
<!-- this is an html comment -->
<DIV>
<div></div>
<p>
<P>
<SPAN>
<span style="stuff and yo">
<a href=""><img src="https://lanl.com"></a>
Here is: more text';
my $regex = qr/(<(/|)(!--|div|span|a|img|p)[^>]*>(\n|)| )/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";