const regex = new RegExp('^users/(?P<pk>\\d+)(?:/(?P<username>[-\\w]+))?(?:/(?P<tab>[-\\w]+))?/?', 'gm')
const str = `users/24
users/24/
users/24/sam
users/24/sam/
users/24/sam/tab_name
users/24/sam/tab_name/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}