re = /^users\/(?P<pk>\d+)(?:\/(?P<username>[-\w]+))?(?:\/(?P<tab>[-\w]+))?\/?/m
str = 'users/24
users/24/
users/24/sam
users/24/sam/
users/24/sam/tab_name
users/24/sam/tab_name/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end