$re = '/^(.{2,})\1{2,}$/m';
$str = 'Valid:
ababab
ab ab ab
ab ab ab
aaaaaa
Invalid:
aaaa
abcde
ab ab ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);