#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\.\d\d[1-9]?)\d*"
Local $sString = "3.820" & @CRLF & _
"11.325" & @CRLF & _
"60.100" & @CRLF & _
"441.005" & @CRLF & _
"11.23028741" & @CRLF & _
"1007.3335471" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)