use strict;
my $str = '3.820
11.325
60.100
441.005
11.23028741
1007.3335471
';
my $regex = qr/(\.\d\d[1-9]?)\d*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";