import Foundation
let pattern = #"^([A-Za-z0-9]\s?)+\s-\s(Before|After)\s((Insert|Update|Delete)|(Insert\/Update))\s-\s([A-Za-z0-9]\s?)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Valid Cases matching standards:
Opportunity - Before Insert/Update - Update Amount Before We Die
Case - After Update - Send Notification
Lead - Before Delete - Archive Record
Opportunity Line Item - After Insert - 123 sdsad asdasd
Quote Line Asset - Before Insert - Hello World
Account - After Update - Yes Man This Can Be Anything
Invalid cases:
account - Before Save - Update Name (Object should start with an uppercase letter)
Account - before save - Update Name (Context should start with an uppercase letter)
Account - Before Save - update name (Action should start with an uppercase letter)
Account-Before Save-Update Name (Missing spaces around hyphens)
Account - Before/After Save - Update Name (Invalid characters in Context)
Custom_Object__c - After Undelete - Restore Record
Opportunity_Line_Item - Before Insert - Validate Quantity
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)