// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?s)\.getModification\(\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\)"#).unwrap();
let string = "
val color = Flagship.getModification(\"btnColor\", \"#0e5fe3\", true)
val size = Flagship.getModification(\"btnSize\", 13, true)
val display = Flagship.getModification(\"displayBtn\", true, true)
val color = Flagship.getModification(\"btnColor\", \"#0e5fe3\")
val size = Flagship.getModification(\"btnSize\", -0.1)
val display = Flagship.getModification(\"displayBtn\", true)
val color = Flagship.getModification(\"btnColor\", \"(hello world !)\", true)
val size = Flagship.getModification(\"btnSize\", \"red, green blue\", true)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}