use strict;
my $str = '- test 1
test test test
test test test
test test test
- test2
- test3
test test t
test test test
- test 4
test test test
- test5
';
my $regex = qr/(?<=^\h\h)([^-\s].*)\R(?!-)\h*/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";