# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^-]+) - ([^-]+) - ([0-9]+\.) (.*)$"
test_str = ("Nirvana - From The Muddy Banks Of The Whiskah - 01. Intro.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 02. School.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 03. Drain You.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 04. Aneurysm.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 05. Smells Like Teen Spirit.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 06. Been A Son.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 07. Lithium.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 08. Sliver.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 09. Spank Thru.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 10. Scentless Apprentice.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 11. Heart-Shaped Box.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 12. Milk It.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 13. Negative Creep.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 14. Polly.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 15. Breed.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 16. Tourette's.mp3\n"
"Nirvana - From The Muddy Banks Of The Whiskah - 17. Blew.mp3")
subst = "$3 Album: $2 From $1 - $4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.