package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`,google\b|\bgoogle,|\bgoogle\b`)
var str = `botgoogle,googlebot,google,bot,bing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}