package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<remotename>\w*)(?<seperator>\/)(?<branchname>\w*)`)
var str = `origin/master`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}