re = />(?=([^\"\']*[\"\'][^\"\']*[\"\'])*(?![^\"\']*[\"\']))/m
str = '> комментарий
print: "((var))"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end