const regex = new RegExp('((\\'|\\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))(\\'|\\").*?(\\n^.*?){0,4}((\\'|\\")[a-zA-Z0-9+/]{40}(\\'|\\"))+|(\\'|\\")[a-zA-Z0-9+/]{40}(\\'|\\").*?(\\n^.*?){0,3}(\\'|\\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))(\\'|\\"))+', 'gm')
const str = `import json
from amazon_pay.client import AmazonPayClient
#client = AmazonPayClient(
# mws_access_key='AKIAJIUGYOGHT2ONMCOQ',
# mws_secret_key='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',
# merchant_id='A2GWANJA6L1J87',
# region='na',
# currency_code='USD',
# sandbox=True)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}