# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[a-z]|\B[A-Z]+)\K(?=[A-Z]\B|\d+)/ /gm;t' <<< "SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF"