using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[a-z]|\B[A-Z]+)\K(?=[A-Z]\B|\d+)";
string substitution = @" ";
string input = @"SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}