$re = '/(?!^)(?=[A-Z][a-z]+|(?<=\D)\d)/m';
$str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF
ROTFLMAO
ServiceOK
ESP';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;