package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(button|color)$`)
var str = `button
color
button123
123color`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}