import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(Weight|Wt\\.) ?\\(kg\\) : )\\d+\\.\\d+(?= Kg)";
final String string = "Weight (kg) : 2.0 Kg\n"
+ "Wt. (kg) : 2.2 Kg\n"
+ "Weight(kg) : 1.5 Kg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}