re = /(?<=(Weight|Wt\.) ?\(kg\) : )\d+\.\d+(?= Kg)/m
str = 'Weight (kg) : 2.0 Kg
Wt. (kg) : 2.2 Kg
Weight(kg) : 1.5 Kg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end