Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^ ?[8\+] ?7?([ \-\(]{1,3})?([0-9]{3}([ \)\-]{1,4})?)|([0-9]{4}([ \)\-]{1,2})?)$
/
mg
Input 1
1
New
84951234567 +74951234567 8-495-1-234-567 8 (8122) 56-56-56 8-911-1234567 8 (911) 12 345 67 8-911 12 345 67 8 (911) - 123 - 45 - 67 + 7 999 123 4567 8 ( 999 ) 1234567 8 999 123 4567 // выше - правильные, ниже - неправильные: 02 84951234567 позвать люсю 849512345 849512345678 8 (409) 123-123-123 7900123467 5005005001 8888-8888-88 84951a234567 8495123456a +1 234 5678901 +8 234 5678901 7 234 5678901
Substitution
84951234567 +74951234567 8-495-1-234-567 8 (8122) 56-56-56 8-911-1234567 8 (911) 12 345 67 8-911 12 345 67 8 (911) - 123 - 45 - 67 + 7 999 123 4567 8 ( 999 ) 1234567 8 999 123 4567 // выше - правильные, ниже - неправильные: 02 84951234567 позвать люсю 849512345 849512345678 8 (409) 123-123-123 7900123467 5005005001 8888-8888-88 84951a234567 8495123456a +1 234 5678901 +8 234 5678901 7 234 5678901