use strict;
my $str = 'bobs burgers dba bobs
100 Oceanside drive
nashville, tn 37204
bobs burgers dba bobs
100 attn Oceanside drive
nashville, tn 37204
bobs burgers dba bobs
100 Oceanside depth drive
nashville, tn fka 37204';
my $regex = qr/\b(attn|co|dba|fka|dept)\b.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";